Cura Profile

When you find your machine has problems. You can have a look at this section
Post Reply
fathead328
Posts: 7
Joined: Thu Oct 08, 2020 3:50 pm

Cura Profile

Post by fathead328 » Thu Oct 08, 2020 4:20 pm

So between reading my manual and looking here, I am confused for what my start G-Code should be for my thinker s...
Would this be correct?

G28 ;Home
M205 X8.00 Y8.00 Z0.40 E1.50;sets the jerk limits
G1 Z15 F1000
G1 Y-3 F1000:Move Y axis
G1 X100 E6 F1000:lines
G1 X150 E12 F1000:lines
M117>>>>>>>>>>>>>>>

Thanks! :)

fathead328
Posts: 7
Joined: Thu Oct 08, 2020 3:50 pm

Re: Cura Profile

Post by fathead328 » Thu Oct 08, 2020 4:22 pm

Also, under Printhead settings, it will not let me change the X min and Y min from 0

NightStorm1000
Posts: 14
Joined: Fri Oct 02, 2020 12:06 am

Re: Cura Profile

Post by NightStorm1000 » Thu Oct 08, 2020 4:29 pm

I use this:

https://github.com/NightHammer1000/Marl ... 0GCODE.txt

It sets the Limits and Primes the Nozzle with a Line on the Left side of the Bed.

fathead328
Posts: 7
Joined: Thu Oct 08, 2020 3:50 pm

Re: Cura Profile

Post by fathead328 » Thu Oct 08, 2020 5:05 pm

Thanks 8-)

fathead328
Posts: 7
Joined: Thu Oct 08, 2020 3:50 pm

Re: Cura Profile

Post by fathead328 » Thu Oct 08, 2020 5:08 pm

I'm thinking my Start G-Code is my problem. I have successfully printed all 3 of the test prints, however when I try to print anything else that I slice through Cura, I've had issues with not sticking, and the quality has not been right. I also noticed that I did not have it set for 1.75mm filament.

User avatar
William
Site Admin
Posts: 248
Joined: Fri May 10, 2019 11:40 pm

Re: Cura Profile

Post by William » Thu Oct 08, 2020 6:18 pm

Hi, I am using this start gcode.
You can have a try with this:

Code: Select all

G90 ; use absolute coordinates
M83 ; extruder relative mode
M104 S170 ; set extruder temp for bed leveling
G28 ; home all without mesh bed level
G29 ; mesh bed leveling 
M104 S[first_layer_temperature] ; set extruder temp

M201 X1000 Y1000 Z200 E5000 ; sets maximum accelerations, mm/sec^2
M203 X200 Y200 Z12 E120 ; sets maximum feedrates, mm/sec
M204 P1250 R1250 T1250 ; sets acceleration (P, T) and retract acceleration (R), mm/sec^2
M205 X8.00 Y8.00 Z0.40 E1.50 ; sets the jerk limits, mm/sec
M205 S0 T0 ; sets the minimum extruding and travel feed rate, mm/sec

G92 E0.0
G1 Y-2.0 X179 F2400
G1 Z3 F720
M109 S[first_layer_temperature] ; wait for extruder temp

; intro line
G1 X170 F1000
G1 Z0.2 F720
G1 X110.0 E8.0 F900
G1 X40.0 E10.0 F700
G92 E0.0

M221 S95 ; set flow
## To be friendly and stay humble
- Pride and ignorance are eternal enemies
:)

NightStorm1000
Posts: 14
Joined: Fri Oct 02, 2020 12:06 am

Re: Cura Profile

Post by NightStorm1000 » Thu Oct 08, 2020 6:24 pm

With the Print not Sticking is often a Bed Leveling Problem.

Make sure your Bed is as Level as it can be. Move the Nozzle to each corner multiple Times and level each corner multiple times with a sheat of Paper.

If you are running 2.0 Firmware you can do a Mesh Bed Level after that to do the fine tuning.

fathead328
Posts: 7
Joined: Thu Oct 08, 2020 3:50 pm

Re: Cura Profile

Post by fathead328 » Fri Oct 09, 2020 1:46 am

NightStorm1000 wrote:
Thu Oct 08, 2020 6:24 pm
With the Print not Sticking is often a Bed Leveling Problem.

Make sure your Bed is as Level as it can be. Move the Nozzle to each corner multiple Times and level each corner multiple times with a sheat of Paper.

If you are running 2.0 Firmware you can do a Mesh Bed Level after that to do the fine tuning.
I am pretty certain my bed is level. The test prints have had no problem sticking. Made sure it was clean, and went to each corner 3-4 times

Post Reply