[Motherboard] Thinker 2560 UART Mode

Post Reply
William
Posts: 24
Joined: Fri May 10, 2019 3:40 pm

[Motherboard] Thinker 2560 UART Mode

Post by William » Tue Sep 10, 2019 7:52 am

Hi, guys!
It has been a long time to get in touch with each other.
Today I've got some info of the Thinker 2560 UART mode

Note: The UART mode for the thinker 2560 V2 motherboard still has some problem.
Now I am trying to contact them and ask them about it.--------------------2019.9.10 updated



Here is some info you need to know at first:
1. This board uses the hardware serial for the UART mode.
Maybe you guys have found tons of the guide for the "TMC2208 UART Mode Setup"
But you know it is based on the software serial.
You need to config the tx/rx pin for the X/Y/Z/E0/E1 at pins.h file.

Software serial UART mode(pins_ramps.h):
UART_1.png
UART_1.png (78.46 KiB) Viewed 320 times
Hardware serial UART mode(pins_ramps.h):
UART_2.png
UART_2.png (52.59 KiB) Viewed 320 times
2. While the default "pins_rambo.h" doesn't include it.
It means we need to copy these lines from "pins_ramps.h" file
Paste it to "pins_rambo.h" and enabled the hardware serial UART mode.

3. Edit the "configuration.h" and "configuration_adv.h"
1) configuration.h
Enable the stepper driver definition
>>Delete "//" to enable it, then set it to "TMC2208"
UART_3.png
UART_3.png (109.21 KiB) Viewed 320 times
2) configuration_adv.h
You can refer to these lines to tuning the current of the TMC2208
UART_4.png
UART_4.png (136.33 KiB) Viewed 320 times
Then enable these lines:
UART_5.png
UART_5.png (57.72 KiB) Viewed 320 times
UART_6.png
UART_6.png (52.82 KiB) Viewed 320 times
UART_7.png
UART_7.png (44.37 KiB) Viewed 320 times
3. Save it then upload it to your motherboard
About this step, check your Arduino IDE have installed the "TMC2208 stepper" to your Arduino Library.
If you forget to install it, your firmware may upload failed.
If not, try to install it. Refer to this pic:
arduino library.png
arduino library.png (31.12 KiB) Viewed 320 times

4. You can use the "M122" gcode to get the information from the TMC2208 board.
Or just tune the current only.


5. Done! Enjoy it!

tomyuan
Posts: 3
Joined: Tue Jun 11, 2019 6:41 am

Re: [Motherboard] Thinker 2560 UART Mode

Post by tomyuan » Tue Sep 10, 2019 9:33 am

Thanks for your sharing!
;)

nephilim
Posts: 1
Joined: Fri Oct 04, 2019 8:09 am

Re: [Motherboard] Thinker 2560 UART Mode

Post by nephilim » Fri Oct 04, 2019 8:11 am

hello,

thanks for sharing this.
I actually have a Thinker S with the Rambo like board.
I have follow your guide, but it isn't work.
i have the TMC Connection error message on LCD screen, and when homing motor does'nt have the right stepping.
Any idea ?

here is the M122 response

Code: Select all

SENT: M122
READ: 		X	Y	Z	E
READ: Enabled		false	false	false	false
READ: Set current	800	800	800	800
READ: RMS current	1436	1436	1436	1436
READ: MAX current	2025	2025	2025	2025
READ: Run current	25/31	25/31	25/31	25/31
READ: Hold current	12/31	12/31	12/31	12/31
READ: CS actual	0/31	0/31	0/31	0/31
READ: PWM scale	0	0	0	0
READ: vsense		0=.325	0=.325	0=.325	0=.325
READ: stealthChop	false	false	false	false
READ: msteps		256	256	256	256
READ: tstep		0	0	0	0
READ: pwm
READ: threshold	1581	1581	10515	4216
READ: [mm/s]		100	100	3	30
READ: OT prewarn	false	false	false	false
READ: OT prewarn has
READ: been triggered	false	false	false	false
READ: off time	0	0	0	0
SENT: M105
READ: blank time	16	16	16	16
READ: hysteresis
READ: -end		-3	-3	-3	-3
READ: -start		1	1	1	1
READ: Stallguard thrs				
READ: DRVSTATUS	X	Y	Z	E
READ: stst					
READ: olb					
READ: ola					
READ: s2gb					
READ: s2ga					
READ: otpw					
READ: ot					
READ: 157C					
READ: 150C					
READ: 143C					
READ: 120C					
READ: s2vsa					
READ: s2vsb					
READ: Driver registers:
READ: 		X	0x00:00:00:00	 Bad response!
READ: 		Y	0x00:00:00:00	 Bad response!
READ: 		Z	0x00:00:00:00	 Bad response!
READ: 		E	0x00:00:00:00	 Bad response!
READ: 
READ: 
READ: Testing X connection... Error: All LOW
READ: Testing Y connection... Error: All LOW
READ: Testing Z connection... Error: All LOW
READ: Testing E connection... Error: All LOW
READ: ok

Post Reply